HomeWordPress vulnerabilitiesGutenslider
Gutenslider vulnerabilities
Gutenslider has 1 known vulnerability in this database. The most recent published record is dated 20 Sep 2021.
- Known vulnerabilities
- 1
- Active installs
- 10,000+
- Latest version
- 7.3.1
- Last updated
- 25 Oct 2026
- Most recent
- 20 Sep 2021
Find it in your WordPress dashboard under Plugins. Severity is based on the CVSS score published with the CVE where one is available.
| Vulnerability | Severity | Affected | Fix | Published |
|---|---|---|---|---|
| Cross-site scripting (XSS) CVE-2021-24640 | Medium 5.4 | Before 5.2.0 | Fixed in 5.2.0 | 20 Sep 2021 |
Read the published descriptions
- CVE-2021-24640, 20 Sep 2021
- The WordPress Slider Block Gutenslider plugin before 5.2.0 does not escape the minWidth attribute of a Gutenburg block, which could allow users with a role as low as contributor to perform Cross-Site Scripting attacks CVE record
What to do if you run Gutenslider
If you run Gutenslider, open WordPress and check the installed version in Plugins. Compare it with the affected versions in the vulnerability record. If a fixed version is available, take a current backup and update to that version or the latest supported release.
If no fixed version exists, consider disabling and removing the plugin or replacing it with a maintained alternative. After dealing with the affected software, check administrator users, unexpected file changes, redirects, unfamiliar pages and security logs for signs that the site may already have been altered.
Email me about new Gutenslider vulnerabilities
Free. We email you when a new vulnerability is published for Gutenslider, usually within minutes. Confirm by email; unsubscribe any time.
Focus on your business. We’ll take care of your website.
From everyday updates to ongoing care, we keep your website working.